Racer audio problem under Ubuntu 10.10 (maverick) resolved

Racer Logo

Since Ubuntu 10.10 (Maverick) removed OSS, “Racer”, in its default configuration has since become rather broken; when you fire Racer up, you’ll get the following error:

Audio: setting speakermode to -1081005172 (<unknown_speakermode>, system default is <unknown_speakermode>)
FMOD: audio hardware acceleration is OFF. This is really bad for latency; adjusting audio buffers.
Can't init FMOD (audio system)

The solution? Simply replace the old libfmodex.so with the latest one!

# Download and extract the latest version of fmod
wget http://www.fmod.org/index.php/release/version/fmodapi43208linux.tar.gz
tar -zxf fmodapi43208linux.tar.gz
# Replace the existing libfmodex.so with the latest version
mv fmodapi43208linux/api/lib/libfmodex-4.32.08.so /usr/lib/libfmodex.so
About these ads
Posted in Games, Tips. 1 Comment »

One Response to “Racer audio problem under Ubuntu 10.10 (maverick) resolved”

  1. Klas Says:

    This didn’t work for me…Still gets the same error, I’m on Ubuntu 11.10. Do I have to run a restart afterwards or something?

    Sorry to bother you. Best regards, Klas.


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

%d bloggers like this: